OpenWrt und Wlan-Mesh (II)

Wir steigen dann in die Kommandozeile und geben ein nano /etc/config/wireless

Am Ende der Datei geben wir ein:

config wifi-iface 'mesh'
option network 'mesh lan'
option device 'radio0'
option mode 'mesh'
option mesh_id 'housemesh'
option encryption 'sae'
option key 'meshpasswort'
option mesh_fwding '1'

Obiges gilt jetzt für ein einfaches 2,4GHz Wlan, bei 5GHz kaeme analog der Eintrag radio1 dazu. Speichern und das Kommando wifi ausführen, ggf. ein reboot.

Weiter beim Router 1 als MAP (Mesh-Access-Point); fast alles über die Web-Oberfläche:
# WAN wird als Client mit einer IP des DSL-Routers-Netzes versehen: 192.168.178.25
# LAN unter Physical-Settings den Haken bei Enable STP setzen
# DHCP aufsetzen
# WLAN aufsetzen
# LAN mit einer internen IP versehen: 192.168.xx.250
Beim LAN sollte die IP mittels Kommnadozeile nano /etc/config/network eingetragen und mit /etc/init.d/network restart neu gestartet werden.

Weiter beim Router 2,3,4,.. MP (Mesh-Point); analog zu oben, aber:
#Kein WAN notwendig, wird inaktiv bei der Funktion Switch gesetzt, d.h. VLAN2 gelöscht und bei VLAN1 als untagged markiert. Kann als LAN verwendet werden.
# Kein DHCP, da bereits über Router 1 bedient.
# LAN mit einer internen IP versehen: 192.168.xx.251 oder 252, 253,... (jeweils mit GW und DNS von Router 1)

Fertich. Router 2,3,4 können OHNE LAN-Anschluss rumstehen und dasselbe WLAN zur Verfügung stellen, während im Hintergrund das Mesh-Netz alle miteinander verbindet.

Hinweis: obige Topologie ist ein Beispiel, in dem es eine gewollte Trennung zw. DSL-Router und internes Netzwerk umgesetzt wird. Man kann natürlich direkt am DSL-Router hängen, d.h. der sog. MAP wird auch als MP aufgesetzt.

Posted on 4 Oct 2020, 16:18 - Category: OpenWrt
No comments - Edit - Delete


OpenWrt und Wlan-Mesh (I)

Eigentlich recht einfach, wenn man den Dreh raushat und endlich versteht. Bin halt kein Netzwerk-Pro... meistens ist die Dokumentation sowas von kompliziert geschrieben, um ja auch den Pros was zu bieten.

Nachdem man einmal den Router seiner/ihrer Wahl - möglichst mit >8Mb - gewählt und idealerweise mehrere davon hat, spielt man die aktuelle OpenWrt-Firmware drauf (ueblicherweise die factory).

Da auch die Mesh-Pakete ständig verbessert werden, macht es Sinn wirklich die neuste Firmware zu laden, aktuell irgendwo bei 19.07. Nach der Umwandlung des Routers mit/in OpenWrt, kann man jederzeit mittels sysupgrade zwischen den Versionen springen und testen.

Wir unterscheiden zw. den Mesh-Access-Point und einem Mesh-Point. Ersteres wird wie ein einfacher Router mit WAN und LAN vorab konfiguriert; d.h. mit WAN-Anbindung ans DSL-Modem (heute häufig eine FritzBox). Somit hat man gleich eine Hardware-Netzwerk-Trennung von der Aussenwelt. Beim Zweitem entfallen die Vorarbeiten an der WAN-Schnittstelle.

Vorbereitungen:
# putty installieren - damit wird über ssh mit dem Router kommuniziert. Leider sind nicht alle Einstellungen über LuCi machbar.
# Für Zugriff mit dem WWW sorgen, sei es übers Wlan, oder Lan; denn wir müssen einige Pakete laden.
# Damit der Aufruf mit putty klappt, wird meistens die Vergabe eines Passwortes im Router verlangt. IP lautet bei Erstaufruf: 192.168.1.1

Aktualisierung der Pakete mittels opkg update; danach folgt die Umwandlung:
opkg remove wpad-mini wpad-basic und
opkg install wpad-mesh, optional nano - ein einfacherer Editor als vi.
reboot - ist immer gut.

Posted on 4 Oct 2020, 16:15 - Category: OpenWrt
No comments - Edit - Delete


NetBSD und wlan auf NC10

Ja, es war nervig. FreeBSD hat die Karte erkannt, war aber lahm, OpenBSD nicht, also blieb das bekannte NetBSD für den kleinen Samsung NC10.

Standard-Installation mit mate als X-Window; das kleine Netbook wurde mit einer SSD + 2GB RAM gepimpt, mehr geht eh nicht.

Und nun das Problemchen: die eingebaute wlan-Atheros-Karte AR5212 ist noch nicht wirklich zu 100% Treiberunterstützt, daher auch nicht unter OpenBSD zur Mitarbeit zu bewegen. Vor allem WPA2-AES mag es nicht.

Egal, mein Problem war wohl die Start-Reihenfolge der Services, daher hier (für mich - is ja auch mein Blog) die Konfig-Lesehilfe:

ifconfig.athx
up
ssid "deine AP"
dhcp

rc.conf
dhcpcd=YES
dhcpcd_flags="athx"
# erst dann den Kram für wpa_supplicant
wpa_supplicant=YES
wpa_supplicant_flags="-i athx -c /etc/wpa_supplicant.conf"

wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
network={
ssid="deine AP"
scan_ssid=1
psk="geheim"
key_mgmt="WPA-PSK"
}

Weiterhin kann man einige Zusatzangaben eintragen, aber obiges ist das lauffähige Minimum.

Posted on 10 Jul 2020, 11:13 - Category: NetBSD
No comments - Edit - Delete


AVM 7412 entfritzt (II)

Es folgen die Angaben für den adblock-Addon.

Im Zusammenhang mit stubby werden Werbung und sog. Tracker auf DNS-Ebene gefiltert.
Hierzu werden die Pakete adblock und luci-app-adblock installiert. Eigentlich auch wget (zum Laden der Blocklisten), aber da ist/war wohl ein Problem mit den eingebauten Optionen, was zum Lade-Fehler führt.

Es wird ein neuer Reiter namens Services angezeigt. Hier (s.o.) die nächste Download-Utility über LuCi auswählen (fetch). Die Schnittstelle anpassen (lan oder wan) und unter Blocklist Sources die gewünschten Filter einstellen. Nicht alle, sonst geht vermutlich nix mehr.

Ein Enable Blocklist Backup ist vermutlich nicht verquert, damit im Falle eines Ausfalles wenigstens die alten Blocklisten verfügbar sind.

Unter Scheduled Tasks sollte man folgendes eintragen:
# Adblock Reload
45 05 * * * /etc/init.d/adblock restart

Hierbei werden täglich z.B. um 5:45h die Blocklisten neu aus dem Internet gelesen. Die cron und adblock Services neu starten...!

Man kann das DNS-Reporting via Tool "schöner" einstellen, muss aber nicht.

Das Ganze wurde über mehrere Artikel in der ct behandelt, aber von Mike Kuketz in Form gepresst.
Einen grossen Dank an ihm.




Posted on 14 Jun 2020, 12:55 - Category: OpenWRT
No comments - Edit - Delete


AVM 7412 entfritzt (I)

Alter Hut, aber mangels mehrerer LAN-Anschluesse, kann man das Teil kaum als Router verwenden. Eigentlich als Reservebox gedacht - heute läuft ja alles über DSL - habe ich mich entschieden gemaess c't 09/2020 OpenWrt drauf zu spielen.

Etwas trikky, weil sämtliche Ausnahmen eingetreten sind, aber am Ende wurde die Box erfolgreich mit OpenWrt geflasht. Was nun? VPN ist für mich eher uninteressant, aber ein Adblocker samt DNS over TLS schon eher.

Erstmal wird dnmasq-full und dann stubby installiert; entweder über die Kommandozeile oder halt über die LuCi-Oberfläche:

opkg install dnsmasq-full --download-only && opkg remove dnsmasq && opkg install dnsmasq-full --cache . && rm *.ipk
opkg install stubby

Es folgen die Einstellungen:
uci add_list dhcp.@dnsmasq[-1].server='127.0.0.1#5453'
uci set dhcp.@dnsmasq[-1].noresolv=1
uci commit && reload_config

sowie

uci set network.lan.peerdns='0'
uci set network.lan.dns='127.0.0.1'
uci set network.lanv6.peerdns='0'
uci set network.lanv6.dns='0::1'
uci commit && reload_config

Hierbei auf die Schnittstellennamen achten! In /etc/config/stubby werden ggf. weitere freie DNS-Server nachgetragen. Stubby verwendet standardmaessig Cloudfare.

In globale Parameter noch option tls_min_version '1.2' eintragen; hat was mit der Lastverteilung zu tun.

Weiter mit der Validierung über DNSSEC:
uci set dhcp.@dnsmasq[-1].dnssec=1
uci set dhcp.@dnsmasq[-1].dnsseccheckunsigned=1
uci commit && reload_config

Danach beide Services über LuCi bei /Startup Neustarten. Je nach lokale Netzwerk-Einstellungen sollten alle DNS-Anfragen über die Ex-fritzbox umgeleitet, ggf. per Firewall konfiguriert werden.

Posted on 14 Jun 2020, 12:59 - Category: OpenWRT
No comments - Edit - Delete


Pages: [1] [2] [3] [4] [5] ...