das war knapp II

Ich musste feststellen, dass die IGEL zuviel verbrauchen; da werkelt nun ein hundsalter Axus TC320, auch der mit einem Geode GX1 Chip. Da war wohl coreboot drauf installiert, aber das war für meine Zwecke nix.

Obigen ThinClient habe ich dann mit der Firmware vom Optoma ST320 (zufällige Modellnamensgebung?) reaktiviert. Das Ganze ist auch für den Futro B100 gültig!

Wäre interessant zu erfahren, ob der Compaq Evo T20 auch mit der Firmware funktioniert... Die Spezifikationen sind ja sehr identisch.

Posted on 9 Nov 2014, 11:08 - Category: General
Comments - Edit - Delete


BIOS flashen

Ja, das geht ganz gut, sogar mit Netzwerkkarten. Nicht alle, aber z.B. die Intel pro/100, einige Realtek 8139 oder von 3com bieten einen plcc32 Stecksockel; die ganz alten haben noch einen DIL32-Stecksockel.

Auch hier findet flashrom Anwendung, oder halt die Hersteller eigenen Utils à lá fboot.exe (Intel). Leider ist hier zu beachten, dass die Karten nur 5V ROM's aufnehmen.

Die Wyse haben (warum auch immer) einen 3,6V Baustein. Jedenfalls benötigt man keine teure Hardware. Der Tipp kommt übrigens von hier.

Beim einem ganz alten Board (Axus TC320), der sehr ähnlich dem Optoma ST320E oder Futro B100 ist, war ein DIP32 ROM eingebaut. Mangels geeigneter Netzwerkkarte mit 256k, musste ein alter PC herhalten. Diesmal mit uniflash (siehe webarchive); dieses Tool arbeitet hervorragend mit Boards, obwohl mittels der Option -PCIROM ggf. auch Netzwerkkarten in Frage kommen.

Jedenfalls konnte ich mit dem Fremd-BIOS obiges Gerät zum Leben erwecken. Es tut gerade hier seine Dienste mit sparsamen 9W.

Posted on 3 Oct 2014, 17:22 - Category: General
Comments - Edit - Delete


coreboot

Da das BIOS vom Wyse SX0 sehr zickig ist, hatte ich die im nach hinein nicht so gute Idee gehabt das BIOS mit einem gefixten aus der coreboot-Schmiede zu tauschen. Allerdings ist/war dieser für den Wyse S50 gedacht und der hat nur ein 1024k ROM.

Blöd, dass der S10 ein 2048k ROM besitzt, da dort ein Minisystem (WTOS) noch Platz findet. So, und wie kommt das da drauf? Mit flashrom; ein tolles Tool. Einfach eine Start-CD zusammenbasteln und los.

Ist natürlich vorteilhaft, wenn der ROM-Chip erkannt wird; hier einer von SST in plcc32. Unter Linux macht es Sinn den dmidecode abzuschalten; die Bauteile werden sonst u.U. nicht erkannt. Da das BIOS nur beim Start aktiv ist, kann man den Baustein einfach rausziehen (vorausgesetzt es ist nicht gelötet) und durch ein "leeres" Bauteil ersetzen.

Das Schreiben geschieht dann mit flashrom -w <file>. Danach Neustart, beten und hoffen. Na ja, das war nix... Zum Glück konnte ich das wieder rückgängig machen.

Posted on 3 Oct 2014, 17:08 - Category: General
Comments - Edit - Delete


das war knapp

Puh, und ich sach noch never change a running system...

Ich meinte es ja nur gut und will/wollte etwas energiesparendes einsetzen, als den etwas betagten IGEL 1/1; leider ist der Wyse Sx0 sowas von zickig - hatte ich mittlerweile schon vergessen. Hier sei wieder parkytowers.me.uk erwähnt. M*st. Fast wäre mir der Blog-server samt Inhalt verloren gegangen (backup? was ist ein backup ;-))

Nun denn, schwierig ist/war eher alles wieder zum Laufen zu bringen, da der Wyse Sx0 sich weigert von CF-Karte zu starten, obwohl der Steckplatz vorhanden ist. Da ist wohl der CS_5536 Schuld; beim Starten wird die IDE einfach abgeschaltet (?). Und ich habe den Fehler gemacht die original Installation (zwekcs clonen) zu verwenden und zu vergessen, dass puppylinux in der Version 4.1.2 etwas anders bei Reparaturstarts reagiert.

Egal, nach 2 Tagen Try&Error ist wieder alles da (Liste der pets für später mal):
# Puppylinux 4.1.2r3
# Hiawatha 8.3 mit ReverseProxy, SSL (cmake 2.8.x)
# Instiki 0.9 samt ruby 1.8.7
# Perl 5.8.8 gesamtpaket
# Openssh 1.x (client+server; /var/empty/..)
# ddclient (/var/cache/.. )
# Startup/Xprompt mit sleep xx, killall X
# rc.local (mit obigen Startanweisungen)

Ach ja, und die Zuodnung beim DMZ nicht vergessen (da andere Netzwerk-ID).

Posted on 1 Nov 2014, 20:00 - Category: General
Comments - Edit - Delete


HDD Recovery

Langsam wird es heikel mit der "alten" Hardware; meine Laptops verwenden durchgängig noch IDE/PATA. Hier und dort ergattert man noch schnelle 5400er Festplatten, aber da sind schon einige Sektoren lahm.
So geschehen mit einer gebrauchten ST94019A - die wollte erst gar nicht ansprechbar sein. Die bekannten SeaTools haben hier gleich aufgegeben.
Aber da war doch noch irgendwo eine Rescue-CD mit allen möglichen kleinen Tools, meistens DOSe- oder Linux-basierend.
Hier haben sich mhdd, Vivard und hdat2 als besonders nützlich gezeigt.
Nun, es dauert Stunden bis so ein Durchlauf mit remap vorbei ist, aber in den meisten Fällen arbeiten solche Festplatten noch einige tausend Stunden weiter. Allerdings würde ich denen keine wichtige Daten mehr anvertrauen :) ...

Posted on 5 Oct 2014, 14:13 - Category: General
Comments - Edit - Delete


Pages: [1] [2]